$re = '/^\s*(.*):(\d+):(\d+): (.*):\s*(.*)$/m';
$str = '../GeneratedModel/PortController.cpp:118:37: Warnung: Variable »params« wird nicht verwendet [-Wunused-variable]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);