const regex = /(?<=\s\[)([\sx<>\/])(?=\]\s)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=\\s\\[)([\\sx<>\\\/])(?=\\]\\s)', 'gm')
const str = `# Note that Safari does not support certain lookbehind assertions.
- [ ] Some example task ^2rj7bd6p8pph
- [x] [[Some example task|proj.example.backlog.some-example-task]] ^2rj7bd6p8pph
- [>] Some example task ^2rj7bd6p8pph
- [<] [[Some example task|proj.example.backlog.some-example-task]] ^2rj7bd6p8pph
- [/] Some example task ^2rj7bd6p8pph
- [ ] [[Some example task|proj.example.backlog.some-example-task]] ^2rj7bd6p8pph
| Planned | Actual | % | Task | Backlog |
| ----------: | -----: | :--- | :---------------- | :------ |
| 00:00-00:00 | | [ ] | Some example task | |
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}