$re = '/(?<=\s\[)([\sx<>\/])(?=\]\s)/m';
$str = '# Note that Safari does not support certain lookbehind assertions.
- [ ] Some example task ^2rj7bd6p8pph
- [x] [[Some example task|proj.example.backlog.some-example-task]] ^2rj7bd6p8pph
- [>] Some example task ^2rj7bd6p8pph
- [<] [[Some example task|proj.example.backlog.some-example-task]] ^2rj7bd6p8pph
- [/] Some example task ^2rj7bd6p8pph
- [ ] [[Some example task|proj.example.backlog.some-example-task]] ^2rj7bd6p8pph
| Planned | Actual | % | Task | Backlog |
| ----------: | -----: | :--- | :---------------- | :------ |
| 00:00-00:00 | | [ ] | Some example task | |
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);