$re = '/\w+\s+[|<>]\s+\w+/';
$str = 'some words | other words
some words > other words
some words < other words';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);