re = /\w+\s+[|<>]\s+\w+/
str = 'some words | other words
some words > other words
some words < other words'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end