import Foundation
let pattern = #"https?:\/\/\S+\.[^()]+(?:\([^)]*\))*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
https://testing.go.id/kantal-(1)(2)
(e.g. https://testing.go.id/beginilah-jika-kita-suka-haha)
https://green.kumparan.com/kantal-(1)(2)
(e.g. https://green.kumparan.com/kantal-(1)(2))
(e.g. https://green.kumparan.com/beginilah-jika-kita-suka-haha)
https://green.kumparan.com/kantal-(1)(2)
(e.g. https://green.kumparan.com/beginilah-jika-kita-suka-haha.jpg?haha=hoho&hehe$)
https://blue.kumparan.com/kantal-(1)(2)
(e.g. https://blue.kumparan.com/kantal-(1)(2))
(e.g. https://blue.kumparan.com/beginilah-jika-kita-suka-haha)
https://blue.kumparan.com/kantal-(1)(2)
(e.g. https://blue.kumparan.com/beginilah-jika-kita-suka-haha)
https://blue.kumparan.com/image/upload/f_jpg,fl_progressive,fl_lossy,c_fill,g_face,q_auto:best,w_480,ar_5:7/v1554524445/r6dxtztvmtw9by9oaibe.jpg
url(https://blue.kumparan.com/uikit-assets/assets/logos/404-653d82fd9ae91d1d6cf474e4fd929e47.png)
https://green.kumparan.com/image/upload/fl_progressive,fl_lossy,c_fill,q_auto:best,w_480,ar_5:7/v1553692790/jpgffb7pcs8yo7v0rs2y.jpg
url(https://green.kumparan.com/image/upload/fl_progressive,fl_lossy,c_fill,q_auto:best,w_640/v1554524445/r6dxtztvmtw9by9oaibe.jpg)
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)