re = /\([^()]{1,20}\)(*SKIP)(*FAIL)|,/m
str = 'Get index of this comma, but (not this , comma). Get other commas like, or ,or, 1,1 2 ,2. (not this ,) BUT (get index of this comma, if more than 20 characters are inside the parentheses)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end