using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(^.+?\/\/).+?(@.*$)";
string input = @"http_proxy=""http://QQ@127.0.0.1:8080/""
http://test1:test2@127.0.0.1:8080/
http_proxy=""http://QQ@127.0.0.1:8080/""
http://@127.0.0.1:8080/";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}