re = /(^.+?\/\/).+?(@.*$)/m
str = 'http_proxy="http://QQ@127.0.0.1:8080/"
http://test1:test2@127.0.0.1:8080/
http_proxy="http://QQ@127.0.0.1:8080/"
http://@127.0.0.1:8080/'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end