import re
regex = re.compile(r"[^{\}]+(?=})")
test_str = "<div id=\"text-module-container-eb7272147\" class=\"text-module-container\"><style>#123-module-container-eb7272147 p{text-color:#211E22;bgcolor:test;} #text-module-container-eb7272147 p{color:#211E1E;} #text-module-container-eb7272147 p{color:#123444;} </style><div style=\"background-color: rgb(168, 27, 219); color: rgb(33, 30, 30);\"><span style=\"color:#3498db;\">Click the edit button to replace this conte</span>nt with your own.</div></div>"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")