import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=\\[:de\\]).*?(?=\\[:en\\])";
final String string = "[:de]Some german text 1[:en]Some English text[:] [:de]Some german text 2[:en]Some English text[:]\n"
+ "[:de]Some german text 3[:en]Some English text[:]";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}