re = /(?<=\[:de\]).*?(?=\[:en\])/m
str = '[:de]Some german text 1[:en]Some English text[:] [:de]Some german text 2[:en]Some English text[:]
[:de]Some german text 3[:en]Some English text[:]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end