package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\d+\.)(\d+\.)(\*|\d+)$`)
var str = `1
1.2
1.2.3
111
222.222
111.222.333`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}