#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(xn[-]{2,})?(.*)(\..*)$"
Local $sString = "domain2=@_.com" & @CRLF & _
"my-domain3?$.com" & @CRLF & _
"my---domain3?$.com" & @CRLF & _
"!:domain3?$.com" & @CRLF & _
";,どるdomain7.com" & @CRLF & _
"&)どるdomain6^`.com" & @CRLF & _
"5)my$$$domain4.com" & @CRLF & _
"**my--domain5--.com" & @CRLF & _
"**my--do--main8--.com" & @CRLF & _
"**my---do--main8--.com" & @CRLF & _
"xn-$domain15--.com" & @CRLF & _
"xn-$do--main11--.com" & @CRLF & _
"xn$$do--main12--.com" & @CRLF & _
"ろれっくす.club" & @CRLF & _
"" & @CRLF & _
"xn--domain13--.com" & @CRLF & _
"xn---domain14--.com" & @CRLF & _
"xn--ztt861f.xn--rhqv96g" & @CRLF & _
"xn-----7i8a8a5job0h.xn--1ck2e1b" & @CRLF & _
"xn-----5i4a8a4job0h.xn--1ck2e1b" & @CRLF & _
"xn-----3i4a8c4hob1h.xn--1ck2e1b" & @CRLF & _
"xn-----3i4a8c4hob1h.xo" & @CRLF & _
"xn--do--main9--.xn--gdfkg5454--4cx54----)à-è)-(àfglkdfkgldk" & @CRLF & _
"xn---do--main10--.com" & @CRLF & _
"xn--domain6`.xn--com" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")