import Foundation
let pattern = #"^(xn[-]{2,})?(.*)(\..*)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
domain2=@_.com
my-domain3?$.com
my---domain3?$.com
!:domain3?$.com
;,どるdomain7.com
&)どるdomain6^`.com
5)my$$$domain4.com
**my--domain5--.com
**my--do--main8--.com
**my---do--main8--.com
xn-$domain15--.com
xn-$do--main11--.com
xn$$do--main12--.com
ろれっくす.club
xn--domain13--.com
xn---domain14--.com
xn--ztt861f.xn--rhqv96g
xn-----7i8a8a5job0h.xn--1ck2e1b
xn-----5i4a8a4job0h.xn--1ck2e1b
xn-----3i4a8c4hob1h.xn--1ck2e1b
xn-----3i4a8c4hob1h.xo
xn--do--main9--.xn--gdfkg5454--4cx54----)à-è)-(àfglkdfkgldk
xn---do--main10--.com
xn--domain6`.xn--com
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)