package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([exibebanner [^])(]*)id=["|\']([^"|\']+)`)
var str = `[exibebanner id=|300']`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}