re = /([exibebanner [^])(]*)id=["|\']([^"|\']+)/m
str = '[exibebanner id=|300\']'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end