using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?=<div[ ]class=""aawp"">) # El primer div debe ser con clase aawp
( # primer grupo (será la base de la recursividad)
#--- Opciones ---#
# Cualquier cosa salvo <> una o más veces
[^<>]+
# Cualquier etiqueta vacía (void element)
| <(?=area|base|br|col|embed|hr
|img|input|link|meta|param|source
|track|wbr)\w+[^>]*>
# Comentarios html
| <!-- .*? -->
# Cualquier otra etiqueta (puede tener anidación)
# Recursividad con grupo 1 (?1). El grupo 2 se usa para
# cerrar la misma etiqueta original
| <(\w+)[^>]*>(?1)*</\2>
)
";
string input = @"<div class=""aawp"">
<br>
<div>
<div>asd</div>
</div>
</div>
<div class=""aawp"">
<div id=""aawp-tb-445"">
<div class=""aawp-tb aawp-tb--desktop aawp-tb--cols-5 aawp-tb--hide-labe"">
<a>a</a>
<br />
<img src=""abc"">
<hr>
</div>
<div class=""aawp-tb aawp-tb--desktop aawp-tb--cols-5 aawp-tb--hide-labe"">
...
</div>
<div class=""aawp-tb aawp-tb--desktop aawp-tb--cols-5 aawp-tb--hide-labe"">
...
</div>
</div>
</div>
<div class=""aawp"">
...
</div>
<div class=""aawp"">
<div id=""aawp-tb-445"">
<div class=""aawp-tb aawp-tb--desktop aawp-tb--cols-5 aawp-tb--hide-labe"">
...
</div>
</div>
</div>
<div class=""aawp"">
<div> x </div>
<div> x </div>
</div>
";
RegexOptions options = RegexOptions.Multiline | RegexOptions.Singleline | RegexOptions.IgnorePatternWhitespace;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}