import Foundation
let pattern = ##"""
(?=<div[ ]class="aawp">) # El primer div debe ser con clase aawp
( # primer grupo (será la base de la recursividad)
#--- Opciones ---#
# Cualquier cosa salvo <> una o más veces
[^<>]+
# Cualquier etiqueta vacía (void element)
| <(?=area|base|br|col|embed|hr
|img|input|link|meta|param|source
|track|wbr)\w+[^>]*>
# Comentarios html
| <!-- .*? -->
# Cualquier otra etiqueta (puede tener anidación)
# Recursividad con grupo 1 (?1). El grupo 2 se usa para
# cerrar la misma etiqueta original
| <(\w+)[^>]*>(?1)*</\2>
)
"""##
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .allowCommentsAndWhitespace, .dotMatchesLineSeparators])
let testString = #"""
<div class="aawp">
<br>
<div>
<div>asd</div>
</div>
</div>
<div class="aawp">
<div id="aawp-tb-445">
<div class="aawp-tb aawp-tb--desktop aawp-tb--cols-5 aawp-tb--hide-labe">
<a>a</a>
<br />
<img src="abc">
<hr>
</div>
<div class="aawp-tb aawp-tb--desktop aawp-tb--cols-5 aawp-tb--hide-labe">
...
</div>
<div class="aawp-tb aawp-tb--desktop aawp-tb--cols-5 aawp-tb--hide-labe">
...
</div>
</div>
</div>
<div class="aawp">
...
</div>
<div class="aawp">
<div id="aawp-tb-445">
<div class="aawp-tb aawp-tb--desktop aawp-tb--cols-5 aawp-tb--hide-labe">
...
</div>
</div>
</div>
<div class="aawp">
<div> x </div>
<div> x </div>
</div>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)