import re
regex = re.compile(r"^(?:(?!ab|cd)(.))+$", flags=re.MULTILINE)
test_str = ("This text won\\'t match because it does contain ab in it!\n\n"
"This text won\\'t match because it does contain cd in it!\n\n"
"This text matches because it doesn\\'t contain them in itghdfgdfg!")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")