using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?i)data-rlocation=""([^\r\n""]*)""";
string input = @"<p class=""sm clg"" data-rlocation=""Uttam Nagar East"">Uttam Nagar East, Delhi <span class=""to-txt"" id=""citytt1"">B-24, East Uttam Nagar, Uttam Nagar East,<br>Delhi<span> - </span>110059
<p class=""sm clg"" DATA-rlocation=""Uttam Nagar East"">Uttam Nagar East, Delhi <span class=""to-txt"" id=""citytt1"">B-24, East Uttam Nagar, Uttam Nagar East,<br>Delhi<span> - </span>110059
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}