using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"s(?<![is]s)\b";
string input = @"(""class"",""guests"",""trips"",""sassy"",""basis"",""fruits"")";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}