using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".{4}(.{11}).*";
string input = @"AG1_LN047992593_PB_20200720";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}