package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m).{4}(.{11}).*`)
var str = `AG1_LN047992593_PB_20200720`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}