$re = '/"((?:\\\\"|[^"])*)"|\'((?:\\\\\'|[^\'])*)\'|(\/\/.*|\/\*[\s\S]*?\*\/)/m';
$str = 'alert(\'Say Hello to my li\'l friend");';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);