re = /"((?:\\"|[^"])*)"|'((?:\\'|[^'])*)'|(\/\/.*|\/\*[\s\S]*?\*\/)/m
str = 'alert(\'Say Hello to my li\'l friend");'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end