using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[Rr]e['-]?[Ii]mage";
string input = @"reimage
re-image
Re-image
re-image
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}