package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[Rr]e['-]?[Ii]mage`)
var str = `reimage
re-image
Re-image
re-image
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}