using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[5-9]\d{2,}|\d{4,}";
string input = @"500
100
499
1000
400
1000000
23
5000
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}