import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[5-9]\\d{2,}|\\d{4,}";
final String string = "500\n"
+ "100\n"
+ "499\n"
+ "1000\n"
+ "400\n"
+ "1000000\n"
+ "23\n\n"
+ "5000\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}