import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\";
final String string = "----//---------██████\n"
+ "\\\\--\\/--//----████████\n"
+ "-\\\\-▌-//---██████████████\n"
+ "--\\\\▌//----(▓)--------(▓)\n"
+ "---\\▌/----(▓)---◒►◒---(▓)\n"
+ "----▌------(▓)-- = --(▓)\n"
+ "----▌--------(▓)---(▓)\n"
+ "----▌-----\\(▓)-- ✺ --(▓)/\n"
+ "----▌----(▓)---- ✺ ----(▓)\n"
+ "----▌---(▓)----- ✺ -----(▓)\n"
+ "----▌---(▓)----- ✺ -----(▓)\n"
+ "----▌----(▓)---- ✺ ----(▓)\n"
+ "-----------(▓)(▓)▓(▓)(▓)Reindeer: Dasher - 18 snowman - noh38i1294ry28q9aoeghfdbnfnol - Reindeer: Dancer - 22 snowm@n\n"
+ "▌░░░░██████████████████░░░▐\n"
+ "▌░░░█████████████████████░▐\n"
+ "▌░█████████████████████████\n"
+ "█▐█████▐░░░░░░░░░░░░░░░░░░█\n"
+ "▌█████▌█░░░░░░░░░░░░░░░░░░█\n"
+ "▐█████▌█▀▀▀█████▀▀██████▀▀█\n"
+ "▐█████▐█░▌▌░░░░░▌▐░░░░░▐▐░█\n"
+ "▌█████▐█▌░▌▐▌█▐▐▌▐▌█▐▐▐─▐░█\n"
+ "▌█████▐█░▌▌▀▌██▐▌▐▌██▐▀─▐░█\n"
+ "▌█████▐█▌░▌──────▐──────▐░█\n"
+ "▌▐█▄█▌█░░░▌───▀▄▄▄▄▀───▐▐░█\n"
+ "█▌███▌█░▌░▌▌─▐░░░░░░──▐▐░░█\n"
+ "█▀░░░░▀█░░▌▐▐░▐▄▄▄▄▌░─▌▐▐░█\n"
+ "▌░░░░░░█▐░░▌░░▌▀▀▀▀─░░─░░░█\n"
+ "█░░░░░▐▄░▌░░▐░▐▀▀▀▀░░░▐░▐░█\n"
+ "██▄▄▄▄██▐░▌░░▐░░▐░░░░▐░░░▄█\n"
+ "████████▄░░▐░░▐░░▐░▐░░░▐▄██\n"
+ "██████████▄▄▄▄▄▄▄▄▄▄▄▄▄████\n"
+ "Reindeer: Prancer - 17 snow-man - ae234hi92y489snadklnzxlknikofhewiaofnkxl - Reindeer: Vixen - 19 snow man - m,xn jvkbsjnas kldsasifodska asdak - Reindeer: Comet- 28 snow%man -saskfoldhasiofdnsmklnkxofhio\n"
+ "__________(█)\n"
+ "_______██████\n"
+ "_____ ████████\n"
+ "___███████████\n"
+ "___ (░░░░░░░)░░░)\n"
+ "___(░(░█░░█░)░░░)\n"
+ "__ (░░(░░●░░░)░░░)\n"
+ "__ (░░░░◡░░)░░░░)\n"
+ "_██(░░░░░░░░░░)██\n"
+ "_███(░░░░░░░░░)███\n"
+ "████ ██(░░░)██ ████\n"
+ "████ █████████ ███\n"
+ "████ ████░████ ███\n"
+ "(░░)_ ▓▓▓▓▌▓▐▓▓▓_(░░)\n"
+ "(██) ███████████ (██)\n"
+ "_____█████░█████_▓▓▓\\\n"
+ "_____█████-,█████▓▓▓▓▓)\n"
+ "_____█████-,█████▓▓▓▓▓)\n"
+ "___(░░░░░░)(░░░░░) ▓▓▓▓)\n"
+ "______(███)_(███)▓▓▓▓▓▓)\n"
+ "____ (████)_(████)▓▓▓▓▓)\n"
+ "Reindeer: Cupid - 21 snow#man\n"
+ "░░░░░░░░░░ ★\n"
+ "░░░░░░░░░░██\n"
+ "░░░░░░░░░████\n"
+ "░░░░░░░██▒▒▒▒██\n"
+ "░░░░░██▒▒▒▒▒▒▒▒██\n"
+ "░░░░░░░██▒▒▒▒██\n"
+ "░░░░░░░░██████\n"
+ "░░░░░░░███▓▓███\n"
+ "░░░░░░░░█▓▓▓▓█\n"
+ "░░░░░░░█▓▓▓▓▓▓█\n"
+ "░░░░░░█▓▓▓▓▓▓▓▓█\n"
+ "░░░░░█▓▓▓▓▓▓▓▓▓▓█\n"
+ "░░░████▓▓▓▓▓▓▓▓████\n"
+ "░░█▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓█\n"
+ "░███████▓▓▓▓▓▓███████\n"
+ "░░░░░░█▓▓▓▓▓▓▓▓█\n"
+ "░░░░░█▓▓▓▓▓▓▓▓▓▓█\n"
+ "░░░░█▓▓▓▓▓▓▓▓▓▓▓▓█\n"
+ "░░███▓▓▓▓▓▓▓▓▓▓▓▓███\n"
+ "░█▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓█\n"
+ "███████▓▓▓▓▓▓▓▓███████\n"
+ "░░░░█▓▓▓▓▓▓▓▓▓▓▓▓█\n"
+ "░░░█▓▓▓▓▓▓▓▓▓▓▓▓▓▓█\n"
+ "░░█▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓█\n"
+ "░██▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓██\n"
+ "██████████████████████\n"
+ "░░░░░░░░██████ Reindeer: Donder - 16 snow&man\n"
+ "_____________________________ (██)\n"
+ "__________(█)_______________██████\n"
+ "_________(███)___________ █████████\n"
+ "________(█████)________████████████\n"
+ "______ (███████)______ (░░░░░░░░░░░)\n"
+ "_____(█████████)_____(░░░░█░░█░░░░)\n"
+ "____(██░░░░░░░██)___ (░░(░░░●░░░)░░░)\n"
+ "_____▒░░█░░█░░▒____ (░░░(░░◡░░)░░░░)\n"
+ "____▒░░░░░░░░░░▒___ (░░░░░░░░░░░░░)\n"
+ "____▒░░█░░░█░░░▒___██(░░░░░░░░░)██\n"
+ "____▒░░░███░░░░▒___███(░░░░░░)████\n"
+ "_____▒░░░░░░░░▒___████████████████\n"
+ "_____██░░░░░░██___████████████████\n"
+ "____▒▒███████▒▒___███ █████████ ███\n"
+ "___▒░░░█████░░░▒__███ █████████ ███\n"
+ "_▒░▒░░░███░░░▒░▒__███ █████████ ███\n"
+ "_▒░░▒░░███░░▒░░▒_ ███ █████████ ███\n"
+ "_▒░░░▒░███░▒░░░▒_ (░░) █████████_(░░)\n"
+ "__▒░░▒░███░▒░░▒_______█████████__(██)\n"
+ "_▒▒▒▒░░███░░▒▒▒▒_____█████████__/▓▓▓\\\n"
+ "_▒░░░░░░░░░░░░░▒____ ████__████▓▓▓▓▓▓)\n"
+ "▒░░░░░░░░░░░░░░░▒___████__████▓▓▓▓▓▓▓)\n"
+ "▒░░░░░░░░░░░░░░░▒___████__████▓▓▓▓▓▓▓)\n"
+ "▒░░░░░░░░░░░░░░░▒__(░░░░)_(░░░░)▓▓▓▓▓▓)\n"
+ "▒░░░░░░░░░░░░░░░▒___████__████▓▓▓▓▓▓▓▓)\n"
+ "_▒░░░░░░░░░░░░░▒____ ████__████▓▓▓▓▓▓▓)\n"
+ "__▒▒▒▒▒▒▒▒▒▒▒▒▒______████__████▓▓▓▓▓▓)Reindeer: Rudolph - 31 snow-man\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}