// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\").unwrap();
let string = "----//---------██████
\\\\--\\/--//----████████
-\\\\-▌-//---██████████████
--\\\\▌//----(▓)--------(▓)
---\\▌/----(▓)---◒►◒---(▓)
----▌------(▓)-- = --(▓)
----▌--------(▓)---(▓)
----▌-----\\(▓)-- ✺ --(▓)/
----▌----(▓)---- ✺ ----(▓)
----▌---(▓)----- ✺ -----(▓)
----▌---(▓)----- ✺ -----(▓)
----▌----(▓)---- ✺ ----(▓)
-----------(▓)(▓)▓(▓)(▓)Reindeer: Dasher - 18 snowman - noh38i1294ry28q9aoeghfdbnfnol - Reindeer: Dancer - 22 snowm@n
▌░░░░██████████████████░░░▐
▌░░░█████████████████████░▐
▌░█████████████████████████
█▐█████▐░░░░░░░░░░░░░░░░░░█
▌█████▌█░░░░░░░░░░░░░░░░░░█
▐█████▌█▀▀▀█████▀▀██████▀▀█
▐█████▐█░▌▌░░░░░▌▐░░░░░▐▐░█
▌█████▐█▌░▌▐▌█▐▐▌▐▌█▐▐▐─▐░█
▌█████▐█░▌▌▀▌██▐▌▐▌██▐▀─▐░█
▌█████▐█▌░▌──────▐──────▐░█
▌▐█▄█▌█░░░▌───▀▄▄▄▄▀───▐▐░█
█▌███▌█░▌░▌▌─▐░░░░░░──▐▐░░█
█▀░░░░▀█░░▌▐▐░▐▄▄▄▄▌░─▌▐▐░█
▌░░░░░░█▐░░▌░░▌▀▀▀▀─░░─░░░█
█░░░░░▐▄░▌░░▐░▐▀▀▀▀░░░▐░▐░█
██▄▄▄▄██▐░▌░░▐░░▐░░░░▐░░░▄█
████████▄░░▐░░▐░░▐░▐░░░▐▄██
██████████▄▄▄▄▄▄▄▄▄▄▄▄▄████
Reindeer: Prancer - 17 snow-man - ae234hi92y489snadklnzxlknikofhewiaofnkxl - Reindeer: Vixen - 19 snow man - m,xn jvkbsjnas kldsasifodska asdak - Reindeer: Comet- 28 snow%man -saskfoldhasiofdnsmklnkxofhio
__________(█)
_______██████
_____ ████████
___███████████
___ (░░░░░░░)░░░)
___(░(░█░░█░)░░░)
__ (░░(░░●░░░)░░░)
__ (░░░░◡░░)░░░░)
_██(░░░░░░░░░░)██
_███(░░░░░░░░░)███
████ ██(░░░)██ ████
████ █████████ ███
████ ████░████ ███
(░░)_ ▓▓▓▓▌▓▐▓▓▓_(░░)
(██) ███████████ (██)
_____█████░█████_▓▓▓\\
_____█████-,█████▓▓▓▓▓)
_____█████-,█████▓▓▓▓▓)
___(░░░░░░)(░░░░░) ▓▓▓▓)
______(███)_(███)▓▓▓▓▓▓)
____ (████)_(████)▓▓▓▓▓)
Reindeer: Cupid - 21 snow#man
░░░░░░░░░░ ★
░░░░░░░░░░██
░░░░░░░░░████
░░░░░░░██▒▒▒▒██
░░░░░██▒▒▒▒▒▒▒▒██
░░░░░░░██▒▒▒▒██
░░░░░░░░██████
░░░░░░░███▓▓███
░░░░░░░░█▓▓▓▓█
░░░░░░░█▓▓▓▓▓▓█
░░░░░░█▓▓▓▓▓▓▓▓█
░░░░░█▓▓▓▓▓▓▓▓▓▓█
░░░████▓▓▓▓▓▓▓▓████
░░█▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓█
░███████▓▓▓▓▓▓███████
░░░░░░█▓▓▓▓▓▓▓▓█
░░░░░█▓▓▓▓▓▓▓▓▓▓█
░░░░█▓▓▓▓▓▓▓▓▓▓▓▓█
░░███▓▓▓▓▓▓▓▓▓▓▓▓███
░█▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓█
███████▓▓▓▓▓▓▓▓███████
░░░░█▓▓▓▓▓▓▓▓▓▓▓▓█
░░░█▓▓▓▓▓▓▓▓▓▓▓▓▓▓█
░░█▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓█
░██▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓██
██████████████████████
░░░░░░░░██████ Reindeer: Donder - 16 snow&man
_____________________________ (██)
__________(█)_______________██████
_________(███)___________ █████████
________(█████)________████████████
______ (███████)______ (░░░░░░░░░░░)
_____(█████████)_____(░░░░█░░█░░░░)
____(██░░░░░░░██)___ (░░(░░░●░░░)░░░)
_____▒░░█░░█░░▒____ (░░░(░░◡░░)░░░░)
____▒░░░░░░░░░░▒___ (░░░░░░░░░░░░░)
____▒░░█░░░█░░░▒___██(░░░░░░░░░)██
____▒░░░███░░░░▒___███(░░░░░░)████
_____▒░░░░░░░░▒___████████████████
_____██░░░░░░██___████████████████
____▒▒███████▒▒___███ █████████ ███
___▒░░░█████░░░▒__███ █████████ ███
_▒░▒░░░███░░░▒░▒__███ █████████ ███
_▒░░▒░░███░░▒░░▒_ ███ █████████ ███
_▒░░░▒░███░▒░░░▒_ (░░) █████████_(░░)
__▒░░▒░███░▒░░▒_______█████████__(██)
_▒▒▒▒░░███░░▒▒▒▒_____█████████__/▓▓▓\\
_▒░░░░░░░░░░░░░▒____ ████__████▓▓▓▓▓▓)
▒░░░░░░░░░░░░░░░▒___████__████▓▓▓▓▓▓▓)
▒░░░░░░░░░░░░░░░▒___████__████▓▓▓▓▓▓▓)
▒░░░░░░░░░░░░░░░▒__(░░░░)_(░░░░)▓▓▓▓▓▓)
▒░░░░░░░░░░░░░░░▒___████__████▓▓▓▓▓▓▓▓)
_▒░░░░░░░░░░░░░▒____ ████__████▓▓▓▓▓▓▓)
__▒▒▒▒▒▒▒▒▒▒▒▒▒______████__████▓▓▓▓▓▓)Reindeer: Rudolph - 31 snow-man
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}