$re = '/[^a-z_\s]/m';
$str = ' text List ? this_word.';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;