import re
regex = re.compile(r"[^a-z_\s]", flags=re.MULTILINE)
test_str = " text List ? this_word."
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)