package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\b1\.\b`)
var str = `Item 1 : 1. A method of operating.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}