// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?:194 Temperature[^(\n]+|Airflow_Temperature[^(\n]+|Drive Temperature:|Temperature:) +([0-9]+)").unwrap();
let string = "WD: 194 Temperature_Celsius 0x0022 105 100 000 Old_age Always - 42
Seagate: 194 Temperature_Celsius 0x0022 034 053 000 Old_age Always - 34 (0 16 0 0 0)
Toshiba: 194 Temperature_Celsius 0x0002 122 122 000 Old_age Always - 49 (Min/Max 15/57)";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}