$re = '/news\/[a-z0-9_-]+$/m';
$str = 'news/news_url
news/page/3';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);