import re
regex = re.compile(r"\[(\/?\w+\:?\w+)\]", flags=re.MULTILINE)
test_str = ("\n"
"[shake2][wave]朝から私の大好きな[scream][big]死[/scream][/big]のにおいがするな...[/wave][/shake2]\n"
"[shake2]お前を殺すには骨がおれるが、しかし利益は大きい。ハッハッハ![/shake2]\n"
"[shake2]おや、心がおれそうだって?もう全てを放り出してあきらめたらどうだ。キッド[/shake2]\n"
"[shake2]そんなに死んでしまうのが好きなら、死とチューしちゃえばいいのに![/shake2]\n"
"何か無くなった気がするだって?もし、お前が[icon:camerabadge]カメラバッジを持っているなら、撮影ポーズ中に見回して、その[name]何か[/name]を探してみればいい...\n\n"
"\\[(\\w+)\\](.*)\\[\\/\\1\\]")
subst = "$2"
result = regex.sub(subst, test_str)
if result:
print(result)