// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\[(\/?\w+\:?\w+)\]").unwrap();
let string = "
[shake2][wave]朝から私の大好きな[scream][big]死[/scream][/big]のにおいがするな...[/wave][/shake2]
[shake2]お前を殺すには骨がおれるが、しかし利益は大きい。ハッハッハ![/shake2]
[shake2]おや、心がおれそうだって?もう全てを放り出してあきらめたらどうだ。キッド[/shake2]
[shake2]そんなに死んでしまうのが好きなら、死とチューしちゃえばいいのに![/shake2]
何か無くなった気がするだって?もし、お前が[icon:camerabadge]カメラバッジを持っているなら、撮影ポーズ中に見回して、その[name]何か[/name]を探してみればいい...
\\[(\\w+)\\](.*)\\[\\/\\1\\]";
let substitution = "$2";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}