$re = '/\^(?=[A-Z .()\/-]{1,24}\^)[A-Z .()-]*\/[A-Z .()-]*\^/m';
$str = '^TEST/TEST^
^TEST TEST^
^TEST/TE/ST^
^TEST/TE+ST^
^^
^/^
^/A^
^A/^
^//^
^A/A^';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);