#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\p{Cf}"
Local $sString = "CHARACTER_TABULATION [ ]" & @CRLF & _
"LINE_FEED [" & @CRLF & _
"]" & @CRLF & _
"LINE_TABULATION []" & @CRLF & _
"FORM_FEED []" & @CRLF & _
"]" & @CRLF & _
"SPACE [ ]" & @CRLF & _
"NEXT_LINE [
]" & @CRLF & _
"NON_BREAKING_SPACE [ ]" & @CRLF & _
"OGHAM_SPACE_MARK [ ]" & @CRLF & _
"EN_QUAD [ ]" & @CRLF & _
"EM_QUAD [ ]" & @CRLF & _
"EN_SPACE [ ]" & @CRLF & _
"EM_SPACE [ ]" & @CRLF & _
"THREE_PER_EM_SPACE [ ]" & @CRLF & _
"FOUR_PER_EM_SPACE [ ]" & @CRLF & _
"SIX_PER_EM_SPACE [ ]" & @CRLF & _
"FIGURE_SPACE [ ]" & @CRLF & _
"PUNCTUATION_SPACE [ ]" & @CRLF & _
"THIN_SPACE [ ]" & @CRLF & _
"HAIR_SPACE [ ]" & @CRLF & _
"LINE_SEPARATOR [
]" & @CRLF & _
"PARAGRAPH_SEPARATOR [
]" & @CRLF & _
"NARROW_NON_BREAKING_SPACE [ ]" & @CRLF & _
"MEDIUM_MATHEMATICAL_SPACE [ ]" & @CRLF & _
"IDEOGRAPHIC_SPACE [ ]" & @CRLF & _
"MONGOLIAN_VOWEL_SEPARATOR []" & @CRLF & _
"ZERO_WIDTH_SPACE []" & @CRLF & _
"ZERO_WIDTH_NON_JOINER []" & @CRLF & _
"ZERO_WIDTH_JOINER []" & @CRLF & _
"WORD_JOINER []" & @CRLF & _
"ZERO_WIDTH_NON_BREAKING_SPACE []" & @CRLF & _
"INFORMATION_SEPARATOR_1 []" & @CRLF & _
"INFORMATION_SEPARATOR_2 []" & @CRLF & _
"INFORMATION_SEPARATOR_3 []" & @CRLF & _
"INFORMATION_SEPARATOR_4 []" & @CRLF & _
"LEFT_TO_RIGHT_MARK []" & @CRLF & _
"RIGHT_TO_LEFT_MARK []"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")