re = /\p{Cf}/m
str = 'CHARACTER_TABULATION [ ]
LINE_FEED [
]
LINE_TABULATION []
FORM_FEED []
]
SPACE [ ]
NEXT_LINE [
]
NON_BREAKING_SPACE [ ]
OGHAM_SPACE_MARK [ ]
EN_QUAD [ ]
EM_QUAD [ ]
EN_SPACE [ ]
EM_SPACE [ ]
THREE_PER_EM_SPACE [ ]
FOUR_PER_EM_SPACE [ ]
SIX_PER_EM_SPACE [ ]
FIGURE_SPACE [ ]
PUNCTUATION_SPACE [ ]
THIN_SPACE [ ]
HAIR_SPACE [ ]
LINE_SEPARATOR [
]
PARAGRAPH_SEPARATOR [
]
NARROW_NON_BREAKING_SPACE [ ]
MEDIUM_MATHEMATICAL_SPACE [ ]
IDEOGRAPHIC_SPACE [ ]
MONGOLIAN_VOWEL_SEPARATOR []
ZERO_WIDTH_SPACE []
ZERO_WIDTH_NON_JOINER []
ZERO_WIDTH_JOINER []
WORD_JOINER []
ZERO_WIDTH_NON_BREAKING_SPACE []
INFORMATION_SEPARATOR_1 []
INFORMATION_SEPARATOR_2 []
INFORMATION_SEPARATOR_3 []
INFORMATION_SEPARATOR_4 []
LEFT_TO_RIGHT_MARK []
RIGHT_TO_LEFT_MARK []'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end