#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:[^-]*-){2}\s*\K[^/]+"
Local $sString = "a - bc/def_g - A/mn/us/ww" & @CRLF & _
"opq - rs/ts_uf - BC/wx/yza" & @CRLF & _
"Abc - so/dhie7u - XYZ/En/xy/jkq - QWNE"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")