$re = '/-[^-]*$/m';
$str = 'branch:resource-fix-c95e12f
some more test --------------hello
hello -';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);