re = /-[^-]*$/m
str = 'branch:resource-fix-c95e12f
some more test --------------hello
hello -'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end