import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<Major>[a-zA-Z0-9]+)(?:\\.([a-zA-Z0-9]+))+(?<Label>(?:(?:\\-|\\+)?\\w+)+)?";
final String string = "5.6.20.4-dev+a2c4ok ok\n"
+ "1.3.2\n"
+ "12.0.2.1000 ok\n"
+ "3.60.2.300 ok\n"
+ "0.0.2.1-dev ok\n"
+ "2.0.3.1dev ok\n"
+ "this is v1.2.3.1 ok\n"
+ "1.2.3\n"
+ "30.0000.1.222.3333\n"
+ "Not Match\n"
+ "1\n"
+ "1.\n"
+ "12\n"
+ "12.\n"
+ "123\n"
+ "123.";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}