re = /(?<Major>[a-zA-Z0-9]+)(?:\.([a-zA-Z0-9]+))+(?<Label>(?:(?:\-|\+)?\w+)+)?/m
str = '5.6.20.4-dev+a2c4ok ok
1.3.2
12.0.2.1000 ok
3.60.2.300 ok
0.0.2.1-dev ok
2.0.3.1dev ok
this is v1.2.3.1 ok
1.2.3
30.0000.1.222.3333
Not Match
1
1.
12
12.
123
123.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end