#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)<((?(R)strong|div))>((?R)|)<\/\1>"
Local $sString = "<div><strong><div><strong></strong></div></strong></div>" & @CRLF & _
"" & @CRLF & _
"<strong><div></div></strong>" & @CRLF & _
"" & @CRLF & _
"<strong><div><strong></strong></div></strong>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")