$re = '/<((?(R)strong|div))>((?R)|)<\/\1>/m';
$str = '<div><strong><div><strong></strong></div></strong></div>
<strong><div></div></strong>
<strong><div><strong></strong></div></strong>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);