import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(.*)\\s*\\((.*?)\\)|(.*)";
final String string = "Aerospace Technologies of Australia Pty Ltd (Australia)\n"
+ "American Tactical Aircraft Consultants (United States)\n"
+ "ATEC vos (Czech Republic)\n"
+ "Aviation Technology Group Inc (United States)\n"
+ "Atlas Aircraft Corporation of South Africa (Pty) Ltd (South Africa)\n"
+ "GIE Avions de Transport Régional (France/Italy)\n"
+ "Auster Aircraft Ltd (United Kingdom)\n"
+ "Austflight ULA Pty Ltd (Australia)\n"
+ "Australian Aerospace Pty Ltd (Australia)\n"
+ "Australite Inc (United States)\n"
+ "AutoGyro Europe GmbH (Germany)\n"
+ "OOO Samoletstroitelynyi Kompaniya Avantazh (Russia)\n"
+ "AvCraft Aviation LLC (United States)\n"
+ "Aveko sro (Czech Republic)\n"
+ "Azionari Vercellese Industrie Aeronautiche (Italy)\n"
+ "Avia-Zavody Jirího Dimitrova (Czech Republic)\n"
+ "see AERFER and AERMACCHI";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}